Follow

Help! I can't launch or complete an eLearning course

Please keep in mind that your individual course content may have additional requirements above and beyond the browser (e.g. Flash).

Generally speaking, we recommend that you use the most up to date version of your chosen browser.

Here are the minimum system requirements needed to run the eLearning courses in eCompliance:

Item PC Mac
Hardware specs
  • Screen resolution: 1024 x 768 (or above); Internet connection: 4Mb (megabits) or above
  • Screen resolution: 1020 x 768 (or above); Internet connection: 4Mb (megabits) or above
Memory (when playing video)
  • At least 4GB of RAM
  • At least 4GB of RAM
Operating System
  • Windows 7 or higher
  • Mac OS X 10.9 or higher
Browser Support
  • Google Chrome, version 44 and higher
  • Mozilla Firefox, version 44 and higher
  • Internet Explorer, version 11 and higher*
  • Opera, version 12.18 and higher
  • Chrome 44 or higher
Adobe Flash Player
  • Adobe Flash 10.3 or higher
  • Adobe Flash 10.3 or higher
Cookies
  • 3rd party cookies must be accepted
  • 3rd party cookies must be accepted
JavaScript
  • JavaScript must be enabled
  • JavaScript must be enabled

Some organizations have group policies or security settings for Internet Explorer. Those settings can limit the ability to run courses. In that case, you may need to switch to an alternate browser or contact your IT department. 

Was this article helpful?
0 out of 0 found this helpful
Have more questions? Submit a request

Comments

Powered by Zendesk